MacBookのNodeのバージョンを切り替える

まぐろさん

nodeのv12のソース立ち上げようとしたけどMacにv12入ってなかった・・・

nodebrewをインストールした記事はこちら

yarn installで怒られた

Nodeのプロジェクトをビルドするぞ〜っとyarn installをしたところ、下記エラーが

error functions@: The engine "node" is incompatible with this module. Expected version "12". Got "14.13.1"
error Found incompatible module.

v14.13.1じゃなくてv12を使ってねと言われた

欲しいバージョンをインストールする

対象のバージョンをインストールする (※ もう既に入れてたら不要)

$ nodebrew install-binary 12
Fetching: https://nodejs.org/dist/v12.20.0/node-v12.20.0-darwin-x64.tar.gz
############################################################################################################################################################################################################## 100.0%
Installed successfully

ちゃんと入ってるか確認

$ nodebrew ls
v12.20.0
v14.13.1

current: v14.13.1

nodebrew use でバージョンを切り替える

$ nodebrew use v12.20.0
use v12.20.0

nodebrew本当に便利