【npm】最新のnodeにアップデートする

ふぐ

Laravel mixで npm run dev をしたとき、下記エラーが発生した

Error: You are using an unsupported version of Node. Please update to at least Node v12.14

nodeのバージョンが古かったようなので最新版にした時のメモ

npmを使用してアップデートしてく

  • 現在のバージョンを確認
$ node --version
v10.19.0
  • nをインストール
$ sudo npm install -g n
  • 最新バージョンを確認 & インストール
$ n --latest
17.9.0
$ n latest
installing : node-v17.9.0
       mkdir : /usr/local/n/versions/node/17.9.0
       fetch : https://nodejs.org/dist/v17.9.0/node-v17.9.0-linux-x64.tar.xz
   installed : v17.9.0 (with npm 8.5.5)
  • 再度nodeのバージョンを確認
$ node -v
v10.19.0

あれ、変わってない・・・

  • ハッシュをリセットして再度確認
$ hash -r
$ node --version
v17.9.0

あがった