【Laravel】This package requires php 7.4 but your PHP version (7.4.16) does not satisfy that requirement. エラー

えび

Laravel8composer install
This package requires php 7.4 but your PHP version (7.4.16) does not satisfy that requirement.
エラーが発生した…

原因

composerinstallしようとしているパッケージはphp7.4を指定しているのに、
あなたのPHPは7.4.16なので一致しないですよというエラー

composerにphpのバージョンを指定しておくことで解決

composer config platform.php 7.4