【Laravel】 composer require laravel/uiでエラー

コトの経緯

Laravel8がリリースされたので、Laravel7をバージョン指定してインストールした

そのままAuth認証を入れようといつものように下記コマンドを叩くとエラーが・・

$ composer require laravel/ui

 Problem 1
    - Conclusion: remove laravel/framework v7.28.4
    - Conclusion: don't install laravel/framework v7.28.4
    - laravel/ui 3.x-dev requires illuminate/support ^8.0 -> satisfiable by laravel/framework[8.x-dev], illuminate/support[8.x-dev, v8.0.0, v8.0.1, v8.0.2, v8.0.3, v8.0.4, v8.1.0, v8.10.0, v8.11.0, v8.11.1, v8.11.2, v8.2.0, v8.3.0, v8.4.0, v8.5.0, v8.6.0, v8.7.0, v8.7.1, v8.8.0, v8.9.0].
    - laravel/ui v3.0.0 requires illuminate/support ^8.0 -> satisfiable by laravel/framework[8.x-dev], illuminate/support[8.x-dev, v8.0.0, v8.0.1, v8.0.2, v8.0.3, v8.0.4, v8.1.0, v8.10.0, v8.11.0, v8.11.1, v8.11.2, v8.2.0, v8.3.0, v8.4.0, v8.5.0, v8.6.0, v8.7.0, v8.7.1, v8.8.0, v8.9.0].
    - Can only install one of: laravel/framework[8.x-dev, v7.28.4].
    - don't install illuminate/support 8.x-dev|don't install laravel/framework v7.28.4
    - don't install illuminate/support v8.0.0|don't install laravel/framework v7.28.4
    - don't install illuminate/support v8.0.1|don't install laravel/framework v7.28.4
    - don't install illuminate/support v8.0.2|don't install laravel/framework v7.28.4
    - don't install illuminate/support v8.0.3|don't install laravel/framework v7.28.4
    - don't install illuminate/support v8.0.4|don't install laravel/framework v7.28.4
    - don't install illuminate/support v8.1.0|don't install laravel/framework v7.28.4
    - don't install illuminate/support v8.10.0|don't install laravel/framework v7.28.4
    - don't install illuminate/support v8.11.0|don't install laravel/framework v7.28.4
    - don't install illuminate/support v8.11.1|don't install laravel/framework v7.28.4
    - don't install illuminate/support v8.11.2|don't install laravel/framework v7.28.4
    - don't install illuminate/support v8.2.0|don't install laravel/framework v7.28.4
    - don't install illuminate/support v8.3.0|don't install laravel/framework v7.28.4
    - don't install illuminate/support v8.4.0|don't install laravel/framework v7.28.4
    - don't install illuminate/support v8.5.0|don't install laravel/framework v7.28.4
    - don't install illuminate/support v8.6.0|don't install laravel/framework v7.28.4
    - don't install illuminate/support v8.7.0|don't install laravel/framework v7.28.4
    - don't install illuminate/support v8.7.1|don't install laravel/framework v7.28.4
    - don't install illuminate/support v8.8.0|don't install laravel/framework v7.28.4
    - don't install illuminate/support v8.9.0|don't install laravel/framework v7.28.4
    - Installation request for laravel/framework (locked at v7.28.4, required as ^7.24) -> satisfiable by laravel/framework[v7.28.4].
    - Installation request for laravel/ui ^3.0 -> satisfiable by laravel/ui[3.x-dev, v3.0.0].

Installation failed, reverting ./composer.json to its original content.

原因

laravel/uiの最新バージョン(ver.3)でLaravel8のサポートが追加されて
これが指定したLaravelのバージョンと合ってなかったのが原因

バージョン指定してインストールする

2系のバージョンを指定してあげることで解決

composer require laravel/ui:2.*

もしComposerのバージョン指定でエラーが出たら

こちら (※Macの最新版のみ参考になるかも)

【Composer】zsh: no matches found 解消